Baculum xenial package.

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Baculum xenial package.

Piero Ferroni
Hi,
I need to install baculum on Ubuntu 16.04 Xenial but until now I did not
find any xenial specific package.
Is somebody working on a xenial package? If so, is there any estimated
date for its release?

Best regards.

--
Piero Ferroni


------------------------------------------------------------------------------
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Reply | Threaded
Open this post in threaded view
|

Re: Baculum xenial package.

Marcin Haba
Hello Piero,

I saw your message here from a few days but I didn't have time to
respond here. Now I am trying to catch up reading mails from mailing
groups.

Answering to your question - no, there isn't Baculum packages for
Ubuntu 16.04 Xenial. I can prepare these pacakges but for now I can
prepare them with "unstable" mark, because I still need time to test
these new packages. If you and anybody else are interested Baculum
packages for Ubuntu 16.04 please let me know here. I will prepare them
in the beginning of next week.

Please note that from Baculum packages for 15.10 there isn't too many
big changes to Baculum. There are only minor changes. In the future I
will add more new features.

Best regards.
Marcin Haba (gani)

On 14 September 2016 at 17:48, Piero Ferroni <[hidden email]> wrote:

> Hi,
> I need to install baculum on Ubuntu 16.04 Xenial but until now I did not
> find any xenial specific package.
> Is somebody working on a xenial package? If so, is there any estimated
> date for its release?
>
> Best regards.
>
> --
> Piero Ferroni
>
>
> ------------------------------------------------------------------------------
> _______________________________________________
> Bacula-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/bacula-users



--
"Większej miłości nikt nie ma nad tę, jak gdy kto życie swoje kładzie
za przyjaciół swoich." Jezus Chrystus

------------------------------------------------------------------------------
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Reply | Threaded
Open this post in threaded view
|

Re: Baculum xenial package.

Marcin Haba
Hello Piero,

I let know that I prepared Baculum 7.4.4 packages for Ubuntu 16.04. I
tested them so I added them to official Baculum packages repository.

Here is the repository definition for Ubuntu 16.04:

deb [ arch=amd64 ] http://bacula.org/downloads/baculum/ubuntu xenial main
deb-src http://bacula.org/downloads/baculum/ubuntu xenial main

The most important change in these packages is using metapackages for
PHP that currently install modules for PHP 7.

For upgrades please note that because of the new depenencies to PHP 7,
there isn't possible to upgrade Baculum by command:

apt-get upgrade

but there is required using:

apt-get dist-upgrade

After upgrading packages, I recommend to remove all Baculum cache from
directory:

/var/cache/baculum/

by removing directories inside this directory. This cache will be
re-created by Baculum automatically after using Baculum interface.

More information about Baculum you can find here:

http://www.bacula.org/7.4.x-manuals/en/console/Baculum_Web_GUI_Tool.html

In near feature I will prepare packages for rest distributions
(Debian, Fedora, Centos...).

Best regards.
Marcin Haba (gani)

On 30 September 2016 at 10:43, Marcin Haba <[hidden email]> wrote:

> Hello Piero,
>
> OK, thanks. I will let you know and I will let know on bacula-users
> list when these packages are ready.
>
> It will be somewhe within one week, I think.
>
> Best regards.
> Marcin
>
>
> On 30 September 2016 at 10:41, Piero Ferroni <[hidden email]> wrote:
>> Hi,
>>
>> only now I read your proposal to prepare a Baculum package for Ubuntu 16.04
>> Xenial.
>> If the proposal is still valid I would accept it. Also for a version with
>> "unstable" mark.
>>
>> Best regards.
>> Piero Ferroni
>>
>>
>> Il 23/09/2016 13:11, Marcin Haba ha scritto:
>>>
>>> Hello Piero,
>>>
>>> I saw your message here from a few days but I didn't have time to
>>> respond here. Now I am trying to catch up reading mails from mailing
>>> groups.
>>>
>>> Answering to your question - no, there isn't Baculum packages for
>>> Ubuntu 16.04 Xenial. I can prepare these pacakges but for now I can
>>> prepare them with "unstable" mark, because I still need time to test
>>> these new packages. If you and anybody else are interested Baculum
>>> packages for Ubuntu 16.04 please let me know here. I will prepare them
>>> in the beginning of next week.
>>>
>>> Please note that from Baculum packages for 15.10 there isn't too many
>>> big changes to Baculum. There are only minor changes. In the future I
>>> will add more new features.
>>>
>>> Best regards.
>>> Marcin Haba (gani)
>>>
>>> On 14 September 2016 at 17:48, Piero Ferroni <[hidden email]>
>>> wrote:
>>>>
>>>> Hi,
>>>> I need to install baculum on Ubuntu 16.04 Xenial but until now I did not
>>>> find any xenial specific package.
>>>> Is somebody working on a xenial package? If so, is there any estimated
>>>> date for its release?
>>>>
>>>> Best regards.
>>>>
>>>> --
>>>> Piero Ferroni
>>>>
>>>>
>>>>
>>>> ------------------------------------------------------------------------------
>>>> _______________________________________________
>>>> Bacula-users mailing list
>>>> [hidden email]
>>>> https://lists.sourceforge.net/lists/listinfo/bacula-users
>>>
>>>
>>>
>>
>
>
>
> --
> "Greater love hath no man than this, that a man lay down his life for
> his friends." Jesus Christ
>
> "Większej miłości nikt nie ma nad tę, jak gdy kto życie swoje kładzie
> za przyjaciół swoich." Jezus Chrystus



--
"Greater love hath no man than this, that a man lay down his life for
his friends." Jesus Christ

"Większej miłości nikt nie ma nad tę, jak gdy kto życie swoje kładzie
za przyjaciół swoich." Jezus Chrystus

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Reply | Threaded
Open this post in threaded view
|

Re: Baculum xenial package.

Márcio Merlone
Em 08/10/2016 17:14, Marcin Haba escreveu:
I let know that I prepared Baculum 7.4.4 packages for Ubuntu 16.04. I
tested them so I added them to official Baculum packages repository.

Here is the repository definition for Ubuntu 16.04:

deb [ arch=amd64 ] http://bacula.org/downloads/baculum/ubuntu xenial main
deb-src http://bacula.org/downloads/baculum/ubuntu xenial main

The most important change in these packages is using metapackages for
PHP that currently install modules for PHP 7.
Hi,

I am trying to install Baculum on a Ubuntu 16.04 server with no luck, it looks for a php5 package, which is not available:

root@phobos:/var/www/html/baculum# apt install baculum-apache2 baculum
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 baculum : Depends: php5-cgi but it is not installable
           Depends: php5-curl but it is not installable
           Depends: php5-json but it is not installable
           Depends: php5-mysql but it is not installable
           Depends: php5-pgsql but it is not installable
           Depends: php5-sqlite but it is not installable
 baculum-apache2 : Depends: libapache2-mod-php5 but it is not installable
E: Unable to correct problems, you have held broken packages.
root@phobos:/var/www/html/baculum#

Any hint?

--
Marcio Merlone

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Reply | Threaded
Open this post in threaded view
|

Re: Baculum xenial package.

Marcin Haba
Hello Marcio,

Thanks for the report.

It is a bit strange because latest Baculum 7.4.4 in the stable
packages repository for Ubuntu 16.04 doesn't contain PHP 5
dependencies. I think that you are trying to install an older version
than 7.4.4 or you use other repository than the official.

Here is my test on Ubuntu 16.04:

# LANG=C apt-get install baculum-apache2 baculum
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.4.0-31 linux-headers-4.4.0-31-generic
linux-image-4.4.0-31-generic linux-image-extra-4.4.0-31-generic
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  baculum baculum-apache2
0 upgraded, 2 newly installed, 0 to remove and 275 not upgraded.
Need to get 0 B/1347 kB of archives.
After this operation, 8168 kB of additional disk space will be used.
Selecting previously unselected package baculum.
(Reading database ... 244795 files and directories currently installed.)
Preparing to unpack .../baculum_7.4.4-1_all.deb ...
Unpacking baculum (7.4.4-1) ...
Selecting previously unselected package baculum-apache2.
Preparing to unpack .../baculum-apache2_7.4.4-1_all.deb ...
Unpacking baculum-apache2 (7.4.4-1) ...
Setting up baculum (7.4.4-1) ...
Setting up baculum-apache2 (7.4.4-1) ...


I propose to use Baculum 7.9 beta packages for Ubuntu 16.04.
Installation process is described here:

http://www.bacula.org/7.9.x-manuals/en/console/Baculum_API_Web_GUI_Tools.html#SECTION00340000000000000000

Please note that this version 7.9 beta doesn't support update between
7.4.4 and 7.9. For users with 7.4.4 there is required uninstall 7.4.4
and install 7.9.

Best regards.
Marcin Haba (gani)

On 5 July 2017 at 15:10, Marcio Merlone <[hidden email]> wrote:

> Em 08/10/2016 17:14, Marcin Haba escreveu:
>
> I let know that I prepared Baculum 7.4.4 packages for Ubuntu 16.04. I
> tested them so I added them to official Baculum packages repository.
>
> Here is the repository definition for Ubuntu 16.04:
>
> deb [ arch=amd64 ] http://bacula.org/downloads/baculum/ubuntu xenial main
> deb-src http://bacula.org/downloads/baculum/ubuntu xenial main
>
> The most important change in these packages is using metapackages for
> PHP that currently install modules for PHP 7.
>
> Hi,
>
> I am trying to install Baculum on a Ubuntu 16.04 server with no luck, it
> looks for a php5 package, which is not available:
>
> root@phobos:/var/www/html/baculum# apt install baculum-apache2 baculum
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  baculum : Depends: php5-cgi but it is not installable
>            Depends: php5-curl but it is not installable
>            Depends: php5-json but it is not installable
>            Depends: php5-mysql but it is not installable
>            Depends: php5-pgsql but it is not installable
>            Depends: php5-sqlite but it is not installable
>  baculum-apache2 : Depends: libapache2-mod-php5 but it is not installable
> E: Unable to correct problems, you have held broken packages.
> root@phobos:/var/www/html/baculum#
>
> Any hint?
>
> --
> Marcio Merlone
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> Bacula-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/bacula-users
>



--
"Greater love hath no man than this, that a man lay down his life for
his friends." Jesus Christ

"Większej miłości nikt nie ma nad tę, jak gdy kto życie swoje kładzie
za przyjaciół swoich." Jezus Chrystus

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Reply | Threaded
Open this post in threaded view
|

Re: Baculum xenial package.

Steven Hammond-2
Was curious about this 'Baculum' package so I typed in BACULUM in my
Google search bar.   LOL - I wish now I hadn't.

Steven Hammond



On 7/5/2017 11:35 AM, Marcin Haba wrote:

> Hello Marcio,
>
> Thanks for the report.
>
> It is a bit strange because latest Baculum 7.4.4 in the stable
> packages repository for Ubuntu 16.04 doesn't contain PHP 5
> dependencies. I think that you are trying to install an older version
> than 7.4.4 or you use other repository than the official.
>
> Here is my test on Ubuntu 16.04:
>
> # LANG=C apt-get install baculum-apache2 baculum
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following packages were automatically installed and are no longer required:
>    linux-headers-4.4.0-31 linux-headers-4.4.0-31-generic
> linux-image-4.4.0-31-generic linux-image-extra-4.4.0-31-generic
> Use 'sudo apt autoremove' to remove them.
> The following NEW packages will be installed:
>    baculum baculum-apache2
> 0 upgraded, 2 newly installed, 0 to remove and 275 not upgraded.
> Need to get 0 B/1347 kB of archives.
> After this operation, 8168 kB of additional disk space will be used.
> Selecting previously unselected package baculum.
> (Reading database ... 244795 files and directories currently installed.)
> Preparing to unpack .../baculum_7.4.4-1_all.deb ...
> Unpacking baculum (7.4.4-1) ...
> Selecting previously unselected package baculum-apache2.
> Preparing to unpack .../baculum-apache2_7.4.4-1_all.deb ...
> Unpacking baculum-apache2 (7.4.4-1) ...
> Setting up baculum (7.4.4-1) ...
> Setting up baculum-apache2 (7.4.4-1) ...
>
>
> I propose to use Baculum 7.9 beta packages for Ubuntu 16.04.
> Installation process is described here:
>
> http://www.bacula.org/7.9.x-manuals/en/console/Baculum_API_Web_GUI_Tools.html#SECTION00340000000000000000
>
> Please note that this version 7.9 beta doesn't support update between
> 7.4.4 and 7.9. For users with 7.4.4 there is required uninstall 7.4.4
> and install 7.9.
>
> Best regards.
> Marcin Haba (gani)
>
> On 5 July 2017 at 15:10, Marcio Merlone <[hidden email]> wrote:
>> Em 08/10/2016 17:14, Marcin Haba escreveu:
>>
>> I let know that I prepared Baculum 7.4.4 packages for Ubuntu 16.04. I
>> tested them so I added them to official Baculum packages repository.
>>
>> Here is the repository definition for Ubuntu 16.04:
>>
>> deb [ arch=amd64 ] http://bacula.org/downloads/baculum/ubuntu xenial main
>> deb-src http://bacula.org/downloads/baculum/ubuntu xenial main
>>
>> The most important change in these packages is using metapackages for
>> PHP that currently install modules for PHP 7.
>>
>> Hi,
>>
>> I am trying to install Baculum on a Ubuntu 16.04 server with no luck, it
>> looks for a php5 package, which is not available:
>>
>> root@phobos:/var/www/html/baculum# apt install baculum-apache2 baculum
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>> Some packages could not be installed. This may mean that you have
>> requested an impossible situation or if you are using the unstable
>> distribution that some required packages have not yet been created
>> or been moved out of Incoming.
>> The following information may help to resolve the situation:
>>
>> The following packages have unmet dependencies:
>>   baculum : Depends: php5-cgi but it is not installable
>>             Depends: php5-curl but it is not installable
>>             Depends: php5-json but it is not installable
>>             Depends: php5-mysql but it is not installable
>>             Depends: php5-pgsql but it is not installable
>>             Depends: php5-sqlite but it is not installable
>>   baculum-apache2 : Depends: libapache2-mod-php5 but it is not installable
>> E: Unable to correct problems, you have held broken packages.
>> root@phobos:/var/www/html/baculum#
>>
>> Any hint?
>>
>> --
>> Marcio Merlone
>>
>> ------------------------------------------------------------------------------
>> Check out the vibrant tech community on one of the world's most
>> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>> _______________________________________________
>> Bacula-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/bacula-users
>>
>
>


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Reply | Threaded
Open this post in threaded view
|

Re: Baculum xenial package.

Vanush "Misha" Paturyan-2
In reply to this post by Marcin Haba

On 5 July 2017 at 17:35, Marcin Haba <[hidden email]> wrote:
Hello Marcio,

Thanks for the report.

It is a bit strange because latest Baculum 7.4.4 in the stable
packages repository for Ubuntu 16.04 doesn't contain PHP 5
dependencies. I think that you are trying to install an older version
than 7.4.4 or you use other repository than the official.


​simple "apt-cache policy ​baculum" should show you which repository the "baculum" package is being installed from.

and "apt-cache showpkg baculum" will list its dependencies.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Reply | Threaded
Open this post in threaded view
|

Re: Baculum xenial package.

Márcio Merlone

Hello,

Indeed, forgot I have a ppa (hawq/bacula) for latest bacula packages and it does have a baculum package, sorry for the mess and thanks all for your help.

Best regards.


Em 05/07/2017 14:00, Vanush "Misha" Paturyan escreveu:

On 5 July 2017 at 17:35, Marcin Haba <[hidden email]> wrote:
It is a bit strange because latest Baculum 7.4.4 in the stable
packages repository for Ubuntu 16.04 doesn't contain PHP 5
dependencies. I think that you are trying to install an older version
than 7.4.4 or you use other repository than the official.

​simple "apt-cache policy ​baculum" should show you which repository the "baculum" package is being installed from.

and "apt-cache showpkg baculum" will list its dependencies.

--
Marcio Merlone

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users