Re: [Bacula-devel] Bacula Release 9.0.0

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [Bacula-devel] Bacula Release 9.0.0

Sven Hartge-5
On 10.07.2017 13:41, Kern Sibbald wrote:

> If the Debian release supports installation of older OpenSSLs, please
> that as a solution, otherwise, I suspect that it will take some time --
> unless someone comes up with a patch, in which case, I will attempt to
> hire that person :-)

Debian 8/Jessie contains OpenSSL 1.0.1t (or a backported 1.0.2l if
needed) so everything is fine there.

Debian 9/Stretch contains both OpenSSL 1.0.2l and 1.1.0f. Bacula is
compiled and linked with the 1.0-variant of OpenSSL.

Debian 10/Buster (to be released in mid 2019) will only contain one
OpenSSL release, version 1.1+.

Somewhere between now and the end of 2018 there will be a moment where
OpenSSL-1.0.x will be removed from Debian and every software not adapted
will fail to compile and be subsequently removed from Debian Testing,
the next release-to-be, until it is patched or updated to compile with
the newer OpenSSL.

There is already a Bug in the Debian BTS
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=850895 and Bacula
Bugtracker http://bugs.bacula.org/view.php?id=2247

Grüße,
Sven.


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users

signature.asc (849 bytes) Download Attachment