Quantcast

Sudden Crippling Issues with Bacula.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Sudden Crippling Issues with Bacula.

orocairion
Hello all, for the past few weeks I've had a Bacula deployment running with no issues. But for the past few days there has been a few issues thats has pretty much rendered my Bacula deployment completely useless. 

One of the errors I've getting a lot is "waiting for a mount request" for the two largest jobs, even after restarting the SD and the Director and making sure the Storage is mounted, it happens.

Another one is that status director might show these large as running with no error messages whatsoever, but could spend up to 12 hours with nothing changing. As soon as you cancel and you get the stats for the job, the stats show 0 bytes copied.

Also been getting an error where Bacula will try to create a Volumen, notice that it already exists but then go into waiting mode saying it cannot find any appendable volumes 

08-feb 09:16 bacula-dir JobId 1398: Error: sql_create.c:424 Volume "DB-20170208" already exists.
08-feb 09:16 bacula-dir JobId 1398: Error: sql_create.c:424 Volume "DB-20170208" already exists.
08-feb 09:17 bacula-mirror-sd JobId 1398: Job BkDB.2017-02-08_07.15.00_17 is waiting. Cannot find any appendable volumes.
Please use the "label" command to create a new Volume for

Related to this, for these large jobs it insist on going for full backups even if the previous volume still has enough space to append to it.

I haven't made any major changes to the configuration files that could have caused it to stop working.




------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Sudden Crippling Issues with Bacula.

Uwe Schuerkamp
On Thu, Feb 09, 2017 at 09:57:54AM -0400, Alejandro M wrote:
> Hello all, for the past few weeks I've had a Bacula deployment running with
> no issues. But for the past few days there has been a few issues thats has
> pretty much rendered my Bacula deployment completely useless.
>

I'm wondering if you've hit your pool limitations after the "past few
weeks" and something is wrong with auto-recycling the used volumes?

Some more info on your setup (cfg files) would be helpful.

All the best, Uwe

--
Uwe Schürkamp | email: <[hidden email]>
Arvato Systems S4M GmbH | Sitz Köln | Amtsgericht Köln HRB 27038
Geschäftsführer: Ralf Schürmann | Dr. Manfred Heinen







------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Sudden Crippling Issues with Bacula.

peter.w@thuthuka-ltd.co.uk
In reply to this post by orocairion
Hi

I recently had an issue with the file table in the Bacula DB (mysql)
I did a repair on the table but it was still very slow in backing up so I did purge
and it seemed to clear things up for me
==== ====
SQL I used for REPAIR TABLE <table-name>
and purge
====
REPAIR TABLE file;
PURGE BINARY LOGS BEFORE NOW();

It might be worth checking you DB
regards

>    2. Re: Sudden Crippling Issues with Bacula. (Uwe Schuerkamp)
> ------------------------------
>
> Message: 2
> Date: Fri, 10 Feb 2017 11:12:04 +0100
> From: Uwe Schuerkamp <[hidden email]>
> Subject: Re: [Bacula-users] Sudden Crippling Issues with Bacula.
> To: Alejandro M <[hidden email]>
> Message-ID: <[hidden email]>
> Content-Type: text/plain; charset=iso-8859-1
>
> On Thu, Feb 09, 2017 at 09:57:54AM -0400, Alejandro M wrote:
> > Hello all, for the past few weeks I've had a Bacula deployment
> > running with no issues. But for the past few days there has been a
> > few issues thats has pretty much rendered my Bacula deployment
> > completely useless.
> >
>
> I'm wondering if you've hit your pool limitations after the "past few
> weeks" and something is wrong with auto-recycling the used volumes?
>
> Some more info on your setup (cfg files) would be helpful.
>
> All the best, Uwe
>
> --
> Uwe Sch?rkamp | email: <[hidden email]>
> Arvato Systems S4M GmbH | Sitz K?ln | Amtsgericht K?ln HRB 27038
> Gesch?ftsf?hrer: Ralf Sch?rmann | Dr. Manfred Heinen
  

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Loading...