minimum PostgreSQL version required? (Was: Re: Bacula Release 9.0.1)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

minimum PostgreSQL version required? (Was: Re: Bacula Release 9.0.1)

mark.bergman
In the message dated: Fri, 14 Jul 2017 22:58:26 +0200,
The pithy ruminations from Kern Sibbald on
<[Bacula-users] Bacula Release 9.0.1> were:
=> Hello,
=>
=> We are pleased to announce that we have just released Bacula version 9.0.1

What is the minimum PostgreSQL version required for Bacula 9.0.1?

I'm attempting to build Bacula under CentOS 6.9, using the
distribution-provided PostgreSQL 8.4, and the build is failing with
the error:

        postgresql.c: In member function ?virtual bool BDB_POSTGRESQL::bdb_open_database(JCR*)?:
        postgresql.c:281: error: ?PQconnectdbParams? was not declared in this scope

The Bacula manual states that PostgreSQL "version 7.4 or later"
is supported, but the function PQconnectdbParams seems to have been
introduced with PostgreSQL 9.0

Thanks,

Mark


--
Mark Bergman                                           voice: 215-746-4061      
[hidden email]                              fax: 215-614-0266
https://www.cbica.upenn.edu/
IT Technical Director, Center for Biomedical Image Computing and Analytics
Department of Radiology                         University of Pennsylvania
          PGP Key: https://www.cbica.upenn.edu/sbia/bergman 

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: minimum PostgreSQL version required? (Was: Re: Bacula Release 9.0.1)

Dan Langille
On Jul 18, 2017, at 5:25 PM, [hidden email] wrote:

In the message dated: Fri, 14 Jul 2017 22:58:26 +0200,
The pithy ruminations from Kern Sibbald on
<[Bacula-users] Bacula Release 9.0.1> were:
=> Hello,
=>
=> We are pleased to announce that we have just released Bacula version 9.0.1

What is the minimum PostgreSQL version required for Bacula 9.0.1?

I'm attempting to build Bacula under CentOS 6.9, using the
distribution-provided PostgreSQL 8.4, and the build is failing with
the error:

postgresql.c: In member function ?virtual bool BDB_POSTGRESQL::bdb_open_database(JCR*)?:
postgresql.c:281: error: ?PQconnectdbParams? was not declared in this scope

The Bacula manual states that PostgreSQL "version 7.4 or later"
is supported, but the function PQconnectdbParams seems to have been
introduced with PostgreSQL 9.0

I know I am not answering your question, but I think it is moot with respect to the version you are attempting to use.

PostgreSQL 8.4 was end-of-life in July 2014 : https://www.postgresql.org/support/versioning/

It is no longer receiving any maintenance or security updates. I recommend upgrading.

-- 
Dan Langille - BSDCan / PGCon
[hidden email]


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: minimum PostgreSQL version required? (Was: Re: Bacula Release 9.0.1)

Dan Langille
In reply to this post by mark.bergman
On Jul 18, 2017, at 5:25 PM, [hidden email] wrote:

In the message dated: Fri, 14 Jul 2017 22:58:26 +0200,
The pithy ruminations from Kern Sibbald on
<[Bacula-users] Bacula Release 9.0.1> were:
=> Hello,
=>
=> We are pleased to announce that we have just released Bacula version 9.0.1

What is the minimum PostgreSQL version required for Bacula 9.0.1?

I'm attempting to build Bacula under CentOS 6.9, using the
distribution-provided PostgreSQL 8.4, and the build is failing with
the error:

postgresql.c: In member function ?virtual bool BDB_POSTGRESQL::bdb_open_database(JCR*)?:
postgresql.c:281: error: ?PQconnectdbParams? was not declared in this scope

The Bacula manual states that PostgreSQL "version 7.4 or later"
is supported, but the function PQconnectdbParams seems to have been
introduced with PostgreSQL 9.0

I know I am not answering your question, but I think it is moot with respect to the version you are attempting to use.

PostgreSQL 8.4 was end-of-life in July 2014 : https://www.postgresql.org/support/versioning/

It is no longer receiving any maintenance or security updates. I recommend upgrading.

-- 
Dan Langille - BSDCan / PGCon
[hidden email]


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Loading...