Quantcast

"Block checksum mismatch" error

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

"Block checksum mismatch" error

Vanja Hrustic
I've started using (well, more like testing) Bacula few weeks ago.

Last night, machine where Bacula was running had a hard disk crash, and I've lost all the bacula config files and MySQL database.

I have bacula backup file on another hard disk in the same machine, but I can't even boot into Linux, since main hard disk is dead.

I've booted the system with System Rescue CD. I was able to mount the partition with Bacula volume file. Then, I exported the partition via NFS, and
mounted it on another machine. Since I have no configuration files or anything else, I've create simply bacula-sd.conf (which has Device entry for
this NFS mounted directory), and attempted to use bextract in order to extract files.

At first, I was happy like little child since bextract started restoring files. I guess it does so sequentially, so I assumed it will take a while
(60GB bacula file, ouch :). Basically, Bacula restored files from 1st full backup (was on April 6th). Then it went on 'doing its thing' (no output,
but I presume it was still scanning the volume file), and I hope it would then start restoring files from other differential/incremental backups.
I've also used "-i" option, and specified /root and /home/vanja directories.

I do not have bootstrap file.

Command line was:

../sbin/bextract -i /tmp/list /tmp/rec/bacula/backup_volume0001 /raid/shares/repository/vanja/panic/

(where /tmp/list has 2 lines, /root and /home/vanja; /tmp/rec is NFS mounted, and last dir is local fs)

However, after appx 15 minutes of total work (after it extracted files from 1st full backup, and kept on scanning further), bextract died with:

12-May 16:32 bextract: bextract Error: block.c:304 Volume data error at 1:3851691770! Block checksum mismatch in block 11445: calc=cd7e022f
blk=332fe236
84291 files restored.

I've searched Google and mailing lists, but the only thing I could find was an advice to modify block.c and pray (seemingly, it didn't help to
someone else who tried it).

Now, some questions:

1) What could be the cause of this problem? Can this somehow be 'skipped', or it is "game over" when bacula finds first checksum error (is
everything after it bad data then)? Is it possible that NFS access create problems?

2) Would it make difference if I tried to move that 60GB volume file on local filesystem, instead of accessing it over NFS?

3) Would it make any difference if I reinstalled the machine, setup bacula again, and try to use bscan to recreate database? Would it also 'bomb out'
at the same point if this checksum error exists, or it would possibly skip it and allow me to later on restore files which are near the end of volume
file?

Any help is *much* appreciated.

Thanks.

Vanja

p.s: I'm not subscribed to the list, so please CC me if it is not too much trouble :)



-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7393&alloc_id=16281&op=click
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Loading...