use catalog command in bat does not work in 7.4.X

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

use catalog command in bat does not work in 7.4.X

Xabier Elkano

Hi!,

I've been using bacula version 5.2.13 for a long time and a few weeks
ago I decided to upgrade to 7.4.3. After upgrade, the director and
clients are working very well, but I was using the bat gui client to
manage the backups and I noticed that running the "use catalog" command
in bat is not working anymore (I have a few catalogs). When I run this
command the bat client is frozen and I have to close it and run it
again, the catalog list dialog is not showing up. This command works Ok
trough the bconsole tool.

This works very well in 5.2.13 in the same machine. If I switch to
5.2.13 it works again. I tried 7.4.4 with the same result as with 7.4.3.

Thanks and Best Regards
Xabier


My config.out file content:

Configuration on Tue Oct  4 11:54:46 CEST 2016:

   Host:             x86_64-unknown-linux-gnu -- LinuxMint 17.3
   Bacula version:         Bacula 7.4.4 (28 September 2016)
   Source code location:     .
   Install binaries:         /sbin
   Install libraries:         /usr/lib64
   Install config files:     /etc/bacula
   Scripts directory:         /etc/bacula
   Archive directory:         /tmp
   Working directory:         /opt/bacula/working
   PID directory:         /var/run
   Subsys directory:         /var/run/subsys
   Man directory:         ${datarootdir}/man
   Data directory:         /usr/share
   Plugin directory:         /usr/lib64
   C Compiler:             gcc 4.8.4-2ubuntu1~14.04.3)
   C++ Compiler:         /usr/bin/g++ 4.8.4-2ubuntu1~14.04.3)
   Compiler flags:          -g -O2 -Wall -x c++ -fno-strict-aliasing
-fno-exceptions -fno-rtti
   Linker flags:        
   Libraries:             -lpthread -ldl -ldl
   Statically Linked Tools:  no
   Statically Linked FD:     no
   Statically Linked SD:     no
   Statically Linked DIR:    no
   Statically Linked CONS:   no
   Database backends:         None
   Database port:        
   Database name:         bacula
   Database user:         bacula
   Database SSL options:    

   Job Output Email:         root@localhost
   Traceback Email:         root@localhost
   SMTP Host Address:         localhost

   Director Port:         9101
   File daemon Port:         9102
   Storage daemon Port:      9103

   Director User:        
   Director Group:        
   Storage Daemon User:    
   Storage DaemonGroup:    
   File Daemon User:        
   File Daemon Group:        

   Large file support:         yes
   Bacula conio support:     no
   readline support:         no
   TCP Wrappers support:     no
   TLS support:          yes
   Encryption support:         yes
   ZLIB support:         yes
   LZO support:          yes
   enable-smartalloc:         yes
   enable-lockmgr:         no
   bat support:          yes
   client-only:          yes
   build-dird:             yes
   build-stored:         yes
   Plugin support:         yes
   AFS support:          no
   ACL support:          no
   XATTR support:         yes
   systemd support:         no
   Batch insert enabled:     None


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-devel
Loading...