vchanger not doing "label barcodes" correctly

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

vchanger not doing "label barcodes" correctly

Jason Voorhees
Hello Guys:

This is my first time trying to configure vchanger with Bacula 5.2.13.

I've configured Bacula and vchanger according to the official vchanger
1.0.1 documentation included in source code (vchangerHowto.html).

As per vchanger howto I'm supposed to initialize my magazine by
creating a few volumes by running:

# vchanger /etc/vchanger/vchanger-1.conf createvols 0 3

While it's true that empty volumes are created under the mount point
of my USB disk, they don't get labeled on Bacula. However if I run
"label barcodes" manually from bconsole I'm able to label them without
issues.

The only thing I can "see" is this strange message in vchanger's log file:

mar 13 21:58:01: bconsole: exited with rc=1
mar 13 21:58:01: WARNING! 'update slots' needed in bconsole
mar 13 21:58:01: bconsole: exited with rc=1
mar 13 21:58:01: WARNING! 'label barcodes' needed in bconsole

It seems that after vchanger commands creates the volumes it is unable
to label them through bconsole due to an unknown error. I tried to use
"bconsole = /usr/sbin/bconsole -d 200" in vchanger-1.conf but I can't
get any extra info or verbose messages about the error.

Here's some of my most important configuration:

# /etc/vchanger/vchanger-1.conf
mar 13 21:58:01: bconsole: exited with rc=1
mar 13 21:58:01: WARNING! 'update slots' needed in bconsole
mar 13 21:58:01: bconsole: exited with rc=1
mar 13 21:58:01: WARNING! 'label barcodes' needed in bconsole


# /etc/bacula/bacula-sd.conf
Autochanger {
        Name = usb-vchanger-1
        Device = usb-vchanger-1-drive-0, usb-vchanger-1-drive-1
        Changer Command = "/usr/local/bin/vchanger %c %o %S %a %d"
        Changer Device = "/etc/vchanger/vchanger-1.conf"
}

Device {
        Name = usb-vchanger-1-drive-0
        Drive Index = 0
        Autochanger = yes
        Device Type = File
        Media Type = File
        Removable Media = no
        Random Access = yes
        Maximum Concurrent Jobs = 1
        Archive Device = /var/spool/vchanger/vchanger-1/0
}

Device {
        Name = usb-vchanger-1-drive-1
        Drive Index = 1
        Autochanger = yes
        Device Type = File
        Media Type = File
        Removable Media = no
        Random Access = yes
        Maximum Concurrent Jobs = 1
        Archive Device = /var/spool/vchanger/vchanger-1/1
}

# /etc/bacula/bacula-dir.conf
Storage {
  Name = vchanger-1
  Address = 192.168.1.220
  SDPort = 9103
  Password = 96ba74caf2a7379fd81db4b6e7b82985bafc0aaa
  Device = usb-vchanger-1
  Media Type = File
  Autochanger = yes
  Maximum Concurrent Jobs = 20
}

Hope someone can help me or point me to some place where I can find a
possible solution.

Thanks in advance.

------------------------------------------------------------------------------
Transform Data into Opportunity.
Accelerate data analysis in your applications with
Intel Data Analytics Acceleration Library.
Click to learn more.
http://pubads.g.doubleclick.net/gampad/clk?id=278785231&iu=/4140
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users
Reply | Threaded
Open this post in threaded view
|

Re: vchanger not doing "label barcodes" correctly

Jason Voorhees
Nevermind, I've already solved this. It was due to permissions issue
on /etc/bacula/bconsole.conf not being readable by "tape" group.

Thanks anyway guys :)

On Sun, Mar 13, 2016 at 10:11 PM, Jason Voorhees <[hidden email]> wrote:

> Hello Guys:
>
> This is my first time trying to configure vchanger with Bacula 5.2.13.
>
> I've configured Bacula and vchanger according to the official vchanger
> 1.0.1 documentation included in source code (vchangerHowto.html).
>
> As per vchanger howto I'm supposed to initialize my magazine by
> creating a few volumes by running:
>
> # vchanger /etc/vchanger/vchanger-1.conf createvols 0 3
>
> While it's true that empty volumes are created under the mount point
> of my USB disk, they don't get labeled on Bacula. However if I run
> "label barcodes" manually from bconsole I'm able to label them without
> issues.
>
> The only thing I can "see" is this strange message in vchanger's log file:
>
> mar 13 21:58:01: bconsole: exited with rc=1
> mar 13 21:58:01: WARNING! 'update slots' needed in bconsole
> mar 13 21:58:01: bconsole: exited with rc=1
> mar 13 21:58:01: WARNING! 'label barcodes' needed in bconsole
>
> It seems that after vchanger commands creates the volumes it is unable
> to label them through bconsole due to an unknown error. I tried to use
> "bconsole = /usr/sbin/bconsole -d 200" in vchanger-1.conf but I can't
> get any extra info or verbose messages about the error.
>
> Here's some of my most important configuration:
>
> # /etc/vchanger/vchanger-1.conf
> mar 13 21:58:01: bconsole: exited with rc=1
> mar 13 21:58:01: WARNING! 'update slots' needed in bconsole
> mar 13 21:58:01: bconsole: exited with rc=1
> mar 13 21:58:01: WARNING! 'label barcodes' needed in bconsole
>
>
> # /etc/bacula/bacula-sd.conf
> Autochanger {
>         Name = usb-vchanger-1
>         Device = usb-vchanger-1-drive-0, usb-vchanger-1-drive-1
>         Changer Command = "/usr/local/bin/vchanger %c %o %S %a %d"
>         Changer Device = "/etc/vchanger/vchanger-1.conf"
> }
>
> Device {
>         Name = usb-vchanger-1-drive-0
>         Drive Index = 0
>         Autochanger = yes
>         Device Type = File
>         Media Type = File
>         Removable Media = no
>         Random Access = yes
>         Maximum Concurrent Jobs = 1
>         Archive Device = /var/spool/vchanger/vchanger-1/0
> }
>
> Device {
>         Name = usb-vchanger-1-drive-1
>         Drive Index = 1
>         Autochanger = yes
>         Device Type = File
>         Media Type = File
>         Removable Media = no
>         Random Access = yes
>         Maximum Concurrent Jobs = 1
>         Archive Device = /var/spool/vchanger/vchanger-1/1
> }
>
> # /etc/bacula/bacula-dir.conf
> Storage {
>   Name = vchanger-1
>   Address = 192.168.1.220
>   SDPort = 9103
>   Password = 96ba74caf2a7379fd81db4b6e7b82985bafc0aaa
>   Device = usb-vchanger-1
>   Media Type = File
>   Autochanger = yes
>   Maximum Concurrent Jobs = 20
> }
>
> Hope someone can help me or point me to some place where I can find a
> possible solution.
>
> Thanks in advance.

------------------------------------------------------------------------------
Transform Data into Opportunity.
Accelerate data analysis in your applications with
Intel Data Analytics Acceleration Library.
Click to learn more.
http://pubads.g.doubleclick.net/gampad/clk?id=278785231&iu=/4140
_______________________________________________
Bacula-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bacula-users